Mandrake 9.0 Probleme und deren Umgehung

Problem : "No space left on device"

Laut df bzw. top ist auf den einzelnen Partitionen bzw. im RAM genügend Speicher vorhanden.
Das Problem tritt beim kopieren von großen Backupfiles auf, die die Größe dieses Filesystems überschreiten.
Bei mir war es der Eintrag :

none /tmp tmpfs defaults 0 0

in der /etc/fstab der das Problem verursachte, nach dem Auskommentieren und einem Neustart war das Problem beseitigt.

Problem : "Mounten von CD-ROM und Disketten"

Ein immer wiederkehrendes und nicht totzukriegendes Problem scheint es zu sein, wechselbare Datenträger vernünftig automatisch zu mounten bzw. zu unmounten.
Das Problem äußerte sich bei mir durch die obskuresten Fehlermeldungen von Device nicht vorhanden oder File vorhanden und kein Zugriff möglich usw. usw..
Um das Problem zu beseitigen hilft eigentlich nur eines, nämlich den Supermounter abzuschalten.
Dazu bemüht man das Mandrake-Kontrollzentrum (Sieht jetzt gelungen aus, Lob muß sein!) und wählt Einhängpunkte, dort die CD-ROM und danach die Floppy-Disk. Unter Optionen wählt man den Punkt Supermount ab und bestätigt mit ok. Das war es schon sollte man meinen aber weit gefehlt.

Nach einem Neustart sieht man beim Booten Fehlermeldungen über nicht vorhandene bzw. ungültige Devices. Dies rührt IMO von dem devfs-Daemon her, welcher die Geräte mit neuen Namen anspricht.
Am besten sieht man das im Mandrakekontrollzentrum unter Hardware --> Hardwareliste, dann die CD-ROM wählen, dort fand ich folgenden Eintrag : ide/host0/bus1/target0/lun0/cd, ein anderes Indiz dafür; die Bezeichnung alter Name, neuer Name.
Nach Eintrag in die /etc/fstab ließen sich die Geräte auch wieder ansprechen.
Um beim Booten die Geräte nicht automatisch mit einzubinden, ist noch der Eintrag noauto erforderlich.

Bei mir sieht die /etc/fstab jetzt so aus :

/dev/hda1 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hda6 /home ext3 defaults 1 2
# /dev/hdc /mnt/cdrom auto user,iocharset=iso8859-15,codepage=850, ro,noauto,umask=0 0 0
# /dev/fd0 /mnt/floppy auto user,iocharset=iso8859-15,sync, codepage=850,noauto,umask=0 0 0
/dev/ide/host0/bus1/target0/lun0/cd /mnt/cdrom auto user,iocharset=iso8859-15, codepage=850,ro,noauto,umask=0 0 0
/dev/floppy/0 /mnt/floppy auto user,iocharset=iso8859-15,sync, codepage=850,noauto,umask=0 0 0
none /proc proc defaults 0 0
# none /tmp tmpfs defaults 0 0
/dev/hda5 swap swap defaults 0 0

Von nun an kann man die Medien wie gewohnt mounten : mount /mnt/floppy

Problem : Seltsame Meldungen in Consolenanwendungen; bei mir mc

Meldungen wie :
last=/home/flepied/RPM/BUILD/gpm-1.20.0/src/liblow.c
Dies führt sogar soweit, daß der Midnight-Commander gar nicht mehr lief, das seltsame daran : dieses Problem trat erst nach ca 10 Tagen nach der Installation auf aber nicht auf allen Rechnern.
Das Problem verursacht die Bibliothek libgpm1 welche fehlerhaft zu sein scheint.
Um das Problem zu beseitigen habe ich die Version durch eine ältere ersetzt.
Zu beachten ist, daß man zusätzlich auch das Paket gpm und libgpm-devel downgraden sollte um Komplikationen zu vermeiden.


zuletzt bearbeitet am 28.12.2012